Latest data is not available in Dashboard and Mobile Apps

Incident Report for AWAIR

Resolved

This incident has been fully resolved, and all services are operating normally.
Posted Jun 04, 2026 - 05:45 PDT

Monitoring

A fix has been implemented and we are monitoring the result
Posted Jun 04, 2026 - 01:16 PDT

Investigating

We are currently investigating this issue.
Posted Jun 04, 2026 - 01:13 PDT
This incident affected: Developer APIs (Dashboard Developer APIs), Enterprise Dashboard, and Mobile Apps (Awair Business App).