Account Creation and VOC Sensor Calibration Returning Errors
Incident Report for AWAIR
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 18:00 PDT
Investigating
We are currently investigating this issue.
Posted Jul 19, 2021 - 17:00 PDT
This incident affected: Mobile Apps (Awair Home App).