Awair Home app slow or unresponsive
Incident Report for AWAIR
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 14:39 PDT
Investigating
The app device list page may be slow to load and/or devices may not populate on the list.
Posted Oct 14, 2021 - 12:00 PDT
This incident affected: Mobile Apps (Awair Home App).