Awair Business app does not load

Incident Report for AWAIR

Resolved

This incident has been resolved.
Posted May 03, 2021 - 15:33 PDT

Investigating

We are currently investigating this issue.
Posted May 03, 2021 - 05:15 PDT
This incident affected: Mobile Apps (Awair Business App).