Awair Home App Login Error
Incident Report for AWAIR
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 19:24 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2020 - 13:12 PDT
Investigating
We are currently investigating this issue.
Posted Apr 08, 2020 - 09:00 PDT
This incident affected: App.