Data is not available in Trend tab
Incident Report for AWAIR
Resolved
This incident has been resolved.
Posted Mar 27, 2021 - 09:08 PDT
Investigating
We are currently investigating this issue.
Posted Mar 27, 2021 - 06:30 PDT
This incident affected: Mobile Apps (Awair Business App).